Certificate Portal and Register Slow loading times

Incident Report for JASANZ System Status

Monitoring

A fix has been deployed and we are monitoring.
Posted May 14, 2026 - 15:05 AEST

Investigating

We are investigating slow loading times for the certificate portal and register.
Posted May 14, 2026 - 14:46 AEST
This incident affects: Public Register (Accredited Bodies) and Certificate Upload Portal (Dashboards).